+-

Author Topic: Getting crash from my own pack that previously worked fine...?  (Read 356 times)

Yanniclord

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
  • I'm new!
    • View Profile
Getting crash from my own pack that previously worked fine...?
« on: October 18, 2014, 06:44:56 pm »
Ok so i get straight to it, if you (WThieves) and some others of you remember, i made the KATFYR Pack, wich worked fine in 1.6.4. Now, as i tried it in 1.7.10, and did rename the IDs to NameIDs like 266 to minecraft=gold_ingot, the client atleast started up. However, as i try to put the gun into my inventory, i get this crashlog:

Spoiler (hover to show)

Also by looking over the code i see galacticraft in this, however it cant be, simply cause of ALL other guns work, i mean all of the ones included in the mod and external ones like the mario one. So ye it can only be my gun, just that i dont know whats wrong, if needed just tell me and i will upload my gun pack here.
Thanks in advance. Regards -Yanniclord
« Last Edit: October 18, 2014, 06:48:25 pm by Yanniclord »

Social Buttons


Yanniclord

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
  • I'm new!
    • View Profile

WThieves

  • Administrator
  • Jr. Member
  • *****
  • Posts: 60
  • Karma: +55/-0
    • View Profile
Bump
Because there is a lot more that has changed, at the end of each line there should be some new variables added, I've not yet updated my tutorial.
Without these variables NBT strings remain empty, which means the gun will not work and minecraft will crash.

 

User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

Search



Advanced Search